Archive

April 2014

Browsing

heartbleed

Since people asked: our servers were not vulnerable for the OpenSSL “heartbleed” bug. Not that this is our merit. Even some of the big ones like Google and Yahoo were affected. Quickly after the news about this bug became public we checked our servers and we just happened to be using versions of OpenSSL on our servers that were not affected.

So there is no need to change your accounts passwords on our site because of this, unless you were using the same credentials on sites that were affected.